<< July/2020
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
>>
ワタシの担当している装置なんですけどね。
その装置に組み込むアプリケーション。
現在のメインストリームはVer3.7というバージョンなんですが。
現在構築中で、某所に納める装置は互換性の都合で古いバージョンで構築せよとのこと。

この古いバージョン、仮にVer.2.0としますが、ワタシもよく判らないのです。
ワタシがこの装置を担当した時にはすでにメインストリームはVer3.7でしたし。
Ver2.0とVer3.7ではソフトハウスさんが違って、互換性も全く無し。
イニシャル設定の記述方法も全く異なってて、ワタシの中ではVer2.0はブラックボックス。
使うだけならなんとかなるけど、1から装置にインストールせよってのは難易度がかなり高くて。
なんとか、アレコレいじりながら、9割くらいまで完成しました。

残り1割、どうしても判らなくて、本体のM係長に泣きついてきます。
ただ、M係長もこのアプリが本職ってワケじゃないので、苦労されてるようで。
3人寄れば文殊の知恵って言うけど、3人いなくてM係長とワタシの2人で探ってる状態です。
結局、今日は解決せず、月曜に持ち越しとなってしまいました。

1番簡単な解決方法は。
互換性の問題が出ないように、幾つかの装置をまとめて更新することなんですけどね。
そうすれば、Ver3.7のアプリケーションを使えるし、万々歳なんだけど。
顧客のお財布がそれを許してくれなかったようです・・・。

comments (0) trackback (0)









  
http://blog.minatch.com/tb.php?4128
INFOMATION
 地震で被災された皆さまには
 心よりお見舞い申し上げます。
 2011.03.14
NEW ENTRIES
RECENT COMMENTS
CATEGORIES
ARCHIVES
OTHER
SEARCH
POWERED BY
 Script by ⇒ BLOGN+(ぶろぐん+)
 Skin by ⇒ vivid*face